Pas de connexion sur Fedora

Bonsoir à toutes et tous,

je viens d’acheter un nouvel ordi portable. J’en ai évidemment profité pour directement virer Windows et mettre une Fedora (la 27 qui date de septembre 2018) à la place mais comme je suis vraiment une buse, pas moyen d’obtenir une connexion web filaire ou avec le wifi de la maison (alors qu’elle était bien présente avec Windows sur le même ordi juste avant de tout retirer.

J’ai essayé de faire une recherche sur youtube en tapant quelque chose du genre “comment connecter web filaire fedora” et suis tombé sur la vidéo qui suit :

Mais malgré cette vidéo, je ne suis pas arrivé à configurer tout ça alors que ça paraît assez simple comme en témoigne la vidéo et les captures d’écran qui ont l’air conformes à ce qui se fait dans la vidéo.
01
02
03
04
05 06

Et c’est franchement dommage car je ne peux rien faire avec cet ordi tant que je n’ai pas de connexion web vu que la plupart des logiciels s’installent via une connexion.

Merci à vous pour votre aide.

Steve

Bonsoir
Les paramètres ont l’air corrects.
Je ne comprends pas le matériel. C’est une connexion ethernet via le réseau électrique ?
Sinon en wifi qu’est ce que ça donne, ton réseau est détecté ?

1 J'aime

Bonsoir Pierre,

Le réseau de base est en wifi mais comme la maison est grande, on a été obligés de mettre un appareil pour étendre cette connexion et en plus de ça, on a mis des cpl (et donc la finalité se fait logiquement en ethernet) dans les chambres, d’où la photo du cpl en question.

Je pense qu’il y a déjà un soucis sur le cpl car la connexion via ce chemin ne se fait plus depuis que je l’avais débranché pour transporter l’ordi (de bureau). Je l’ai remis dans ma chambre depuis lors mais plus moyen de me connecter avec ça.

Du coup, avec l’ordi de bureau qui tourne actuellement avec le wifi via windaube 10, y a une connexion en wifi non filaire qui fonctionne pas trop mal.

Et donc, pour le portable, c’est ni filaire, ni wifi, ni partage de connexion via un smartphone.

Merci pour ton aide.

Est-ce que tu peux essayer de faire un test de connectivité avec ton CPL en le branchant dans la même pièce que celui du routeur (en essayant différentes prises s’il le faut) ? ça te confirmerait que ton matériel est fonctionnel dans la configuration (du réseau électrique) la plus simple. Ensuite si ça marche, tester sur d’autres prises et ensuite d’autres pièces se rapprochant de la chambre.

Sinon pour le wifi, si tu es dans la même pièce que le routeur, ça marche ?

Bonjour Pierre et jao,

pour résumer, on a la box internet (Zeop) dans le salon. A l’étage dans une grande pièce, on a un appareil pour augmenter le signal wifi (celui de l’image ci-dessous) sur laquelle il y a 4 ampoules qui sont toutes allumées sauf la deuxième qui représente la connexion filaire.

wifi

Ensuite, dans cette même pièce, on a un cpl (image ci-dessous) avec les trois lampes allumées et qui fonctionne puisque ma coloc (dont la chambre est aussi à l’étage comme moi) qui est connectée avec celui-là me dit qu’elle a internet sur son ordi.

cpl

Et pour finir, j’ai un cpl (celui de la photo de mon premier message) pour moi tout seul dans ma chambre mais avec deux lampes allumées sur les trois. Celle qui n’est pas allumée étant la dernière en bas.

Je fonctionne avec un pc de bureau sur windows (et le portable avec Fedora donc), et suite à ma démarche de dépannage automatique via le paramétrage de windows, il me dit que ethernet n’a pas de configuration IP valide.

ethernet

Je disposais de l’internet filaire au début de son installation. Je l’ai ensuite perdue après avoir tout débranché pour déplacer l’ordi.

Je vais essayer ça. Merci pour la suggestion.

Je suis en wifi avec l’ordi de bureau windows dans ma chambre, mais pas du tout (n’importe où dans la maison) avec l’ordi portable. Et il me donne le message suivant (capture ci-dessous) :

Capture du 2020-04-18 11-24-21

J’ai également essayé via un partage de connexion via mon téléphone et ça ne marche ni sur l’ordi de bureau, ni sur le portable.

Bon ben j’ai essayé dans deux endroits, le premier pas loin de la box dans le salon et le deuxième dans la salle du haut où il y a le premier cpl qui fonctionne bien et c’est pareil qu’avant : deux lampes allumées sur les trois sur mon cpl et Fedora qui me dit que la connexion filaire est en cours pour finir par me dire qu’elle a été impossible à se faire. :expressionless:

Aucun adaptateur Wi Fi trouvé

La carte Wi Fi de l’ordi n’est pas détectée. En premier lieu vérifier si le Wi Fi du portable n’est pas désactivé par un bouton au clavier ou un interrupteur matériel.

C’est vrai que les systèmes d’exploitation fournissent généralement un ensemble de combinaisons de touches ( “Fn+touche” ) qui permet chacun d’activer/désactiver un composant matériel : wifi (et bluetooth), trackpad, mise en veille de l’écran, etc.

Dans le cas d’un diagnostic à distance, on a souvent besoin d’avoir des copié-collé de “résultats de certaines commandes” exécutées dans 1 terminal, et dans ton cas il faudrait que tu copie colle le résultat des commandes suivantes par ex :

  • $ ip a
  • $ lspci

Par exemple chez moi, j’ai comme résultat (partiel) pour les commandes :

$ lspci 
        ... 
        SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
        02:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)
        03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

$ ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> ...
    2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
        link/ether 3c:97:0e:e9:50:cb brd ff:ff:ff:ff:ff:ff
    3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 34:23:87:f7:03:81 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.5/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp2s0
           valid_lft 85665sec preferred_lft 85665sec
        inet6 fe80::c0af:3f54:4e33:5ab2/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever

Ce qui permet de voir que l’OS a bien détecté et installé le pilote pour ma carte wifi et également que le gestionnaire réseau de Gnome (Network Manager) a attribué une adresse IP à la carte wifi.

Donc si besoin, tu peux partager ici le résultat de ces 2 commandes, et quelqu’un y jètera un oeil.


Le résultat de la commande ‘ip a’ renseigne sur le fait que l’OS a reconnu 3 interfaces réseaux :

  • interface lo
  • interface enp3s0
  • interface wlp2s0

Toute interface dont le nom commence par la lettre ‘w’ est distinctif d’une interface wifi. On voit que l’interface wifi a une adresse IP.

Le résultat de la commande ‘lspci’ montre ici qu’une interface wifi a été reconnue par le système :

02:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)

1 J'aime

Merci ! Je vais voir ce qu’il en est et je reviens vers vers vous avec les résultats.

Vu que sous Linux tu n’as pas de réseau si j’ai bien compris, alors tu peux coller le résultat des 2 commandes dans 1 fichier texte, alternativement faire une capture d’écran, et mettre ça sur 1 clé USB.

1 J'aime

Voilà, j’ai les résultats.

J’ai apparemment 2 interfaces réseau mais aucune avec du wifi :

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 7c:8a:e1:16:07:53 brd ff:ff:ff:ff:ff:ff

Et voici le résultat de la deuxième commande :

$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1576
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 1577
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Device 98e4 (rev ea)
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 15b3
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157b
00:02.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c
00:02.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c
00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157b
00:08.0 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1578
00:09.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157d
00:09.2 Audio device: Advanced Micro Devices, Inc. [AMD] Device 157a
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 20)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 4b)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 49)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 4b)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b5
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device c821

La conclusion que je peux déjà en tirer est que je n’ai pas d’interface réseau comprenant le wifi. C’est déjà une piste, je pense.

Oui c’est bien ça, l’OS n’a pas installé le pilote pour ta carte wifi.

Cette ligne de la commande ‘lspci’ semble correspondre à ta carte wifi non reconnue par Fedora lors de l’installation, car on voit

qui indique en principe que ce matériel était inconnu pour Fedora qui n’a pas trouvé de pilote correspondant.

Le plus simple je crois, serait que tu nous indiques le modèle de ton portable (laptop), qu’on puisse faire une recherche.

1 J'aime

Si je comprends bien, tu as un ordinateur portable récent, et ton Fedora ne montre pas d’interface Wifi.
Cela arrive souvent lorsque le firmware de ta puce wifi n’est pas libre.
Pour s’en apercevoir, tapes la commande

sudo dmesg

Et remontes dans l’historique, tu devrais voir les messages d’erreur s’affichaient en rouge.
Cela peut te donner l’indication du firmware non monté.
Quand tu as déterminé quel firmware te manque, il ne te reste plus qu’à le télécharger et le placer au bon endroit pour que le noyau le charge expressément. On parle alors de noyau “teinté”.

À titre indicatif, pour une Debian 10, voici ce que j’ai du faire

* #sudo update-initramfs -u => missing firmware !!!
* git clone https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
* cd linux-firmware
  * sudo mv i915 /lib/firmware/
  * sudo update-initramfs -u # YES
1 J'aime

Mieux, si tu peux fournir le résultat (on dit aussi la sortie) de la commande $ lspci -nv

C’est toujours la commande lspci mais avec l’option -n qui affiche des informations plus précises sur le matériel.

1 J'aime

Bonsoir Philippe,

J’ai donc tapé la commande en question et voici les erreurs qui en sont ressorties :

[    0.014576] [Firmware Bug]: cpu 0, invalid threshold interrupt offset 1 for bank 4, block 0 (MSR00000413=0xd000000001000000)

[    0.717821] ACPI: More than one Lid device found!

[   15.798979] tpm_crb MSFT0101:00: can't request region for resource [mem 0xdfbba000-0xdfbbdfff]

[   16.659231] sp5100_tco: I/O address 0x0cd6 already in use

[   20.000065] Bluetooth: hci0 command 0xfc20 tx timeout

[   28.128058] Bluetooth: hci0: download fw command failed (-110)

Par contre, une ligne qui n’était pas en rouge mais juste en gras a eu le don d’attirer mon attention car elle comportait le mot “error”. La voici :

[ 15.798989] tpm_crb: probe of MSFT0101:00 failed with error -16

J’ai vu qu’il y avait d’autres lignes en gras, si tu les veux aussi, je peux te les copier et ramener ici.

Pour faire simple, j’ai fait une photo de l’étiquette comprenant les infos de la machine :

modele-pc

Voici le résultat de cette commande :

$ lspci -nv
00:00.0 0600: 1022:1576
	Subsystem: 17aa:3811
	Flags: bus master, fast devsel, latency 0

00:00.2 0806: 1022:1577
	Subsystem: 17aa:380e
	Flags: bus master, fast devsel, latency 0, IRQ 24
	Capabilities: <access denied>

00:01.0 0300: 1002:98e4 (rev ea) (prog-if 00 [VGA controller])
	Subsystem: 17aa:39f5
	Flags: bus master, fast devsel, latency 0, IRQ 32
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at f0800000 (64-bit, prefetchable) [size=8M]
	I/O ports at 4000 [size=256]
	Memory at f0500000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

00:01.1 0403: 1002:15b3
	Subsystem: 17aa:380d
	Flags: bus master, fast devsel, latency 0, IRQ 34
	Memory at f0560000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

00:02.0 0600: 1022:157b
	Flags: fast devsel

00:02.2 0604: 1022:157c (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 25
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 00003000-00003fff [size=4K]
	Memory behind bridge: f0400000-f04fffff [size=1M]
	Prefetchable memory behind bridge: 00000000f0100000-00000000f01fffff [size=1M]
	Capabilities: <access denied>
	Kernel driver in use: pcieport
	Kernel modules: shpchp

00:02.4 0604: 1022:157c (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 25
	Bus: primary=00, secondary=02, subordinate=04, sec-latency=0
	I/O behind bridge: 00002000-00002fff [size=4K]
	Memory behind bridge: f1000000-f10fffff [size=1M]
	Prefetchable memory behind bridge: 00000000f0000000-00000000f00fffff [size=1M]
	Capabilities: <access denied>
	Kernel driver in use: pcieport
	Kernel modules: shpchp

00:03.0 0600: 1022:157b
	Flags: fast devsel

00:08.0 1080: 1022:1578
	Subsystem: 17aa:380f
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at f0540000 (64-bit, prefetchable) [size=128K]
	Memory at f0300000 (32-bit, non-prefetchable) [size=1M]
	Memory at f056f000 (32-bit, non-prefetchable) [size=4K]
	Memory at f056a000 (32-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>

00:09.0 0600: 1022:157d
	Flags: fast devsel

00:09.2 0403: 1022:157a
	Subsystem: 17aa:380d
	Flags: bus master, fast devsel, latency 0, IRQ 35
	Memory at f0564000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

00:10.0 0c03: 1022:7914 (rev 20) (prog-if 30 [XHCI])
	Subsystem: 17aa:380b
	Flags: bus master, fast devsel, latency 0, IRQ 18
	Memory at f0568000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: xhci_hcd

00:11.0 0106: 1022:7901 (rev 4b) (prog-if 01 [AHCI 1.0])
	Subsystem: 17aa:380c
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 19
	I/O ports at 4118 [size=8]
	I/O ports at 4124 [size=4]
	I/O ports at 4110 [size=8]
	I/O ports at 4120 [size=4]
	I/O ports at 4100 [size=16]
	Memory at f056c000 (32-bit, non-prefetchable) [size=1K]
	Capabilities: <access denied>
	Kernel driver in use: ahci

00:12.0 0c03: 1022:7908 (rev 49) (prog-if 20 [EHCI])
	Subsystem: 17aa:3813
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
	Memory at f056d000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci

00:14.0 0c05: 1022:790b (rev 4b)
	Subsystem: 17aa:3815
	Flags: 66MHz, medium devsel
	Kernel driver in use: piix4_smbus
	Kernel modules: i2c_piix4, sp5100_tco

00:14.3 0601: 1022:790e (rev 11)
	Subsystem: 17aa:3817
	Flags: bus master, 66MHz, medium devsel, latency 0

00:18.0 0600: 1022:15b0
	Flags: fast devsel

00:18.1 0600: 1022:15b1
	Flags: fast devsel

00:18.2 0600: 1022:15b2
	Flags: fast devsel

00:18.3 0600: 1022:15b3
	Flags: fast devsel
	Capabilities: <access denied>

00:18.4 0600: 1022:15b4
	Flags: fast devsel
	Kernel driver in use: fam15h_power
	Kernel modules: fam15h_power

00:18.5 0600: 1022:15b5
	Flags: fast devsel

01:00.0 0200: 10ec:8136 (rev 07)
	Subsystem: 17aa:385e
	Flags: bus master, fast devsel, latency 0, IRQ 30
	I/O ports at 3000 [size=256]
	Memory at f0400000 (64-bit, non-prefetchable) [size=4K]
	Memory at f0100000 (64-bit, prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: r8169
	Kernel modules: r8169

02:00.0 0280: 10ec:c821
	Subsystem: 17aa:c024
	Flags: fast devsel, IRQ 255
	I/O ports at 2000 [size=256]
	Memory at f1000000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>

Dans un premier temps, voilà le résultat d’une recherche correspondant à ta carte wifi

PS :slight_smile:

  • concernant le message de @pvincent, ça demandait comme il disait une adaptation à ta configuration matérielle, et comme tu n’as pas pu le faire tu as des erreurs

  • c’est remarquable, grâce à Philippe on sait reconnaître maintenant un forum Discourse et la plupart l’utilisent maintenant. Merci Philippe !

1 J'aime

Ok, merci jao. Je vais tâcher de voir ça et voir comment je peux faire pour résoudre le tout.

Ah, je vais essayer de revoir ça en détail ce soir ou demain.

même conclusion que @jao
c’est un souci avec rtl8821ce
principe de résolution pour Debian

https://forums.linuxmint.com/viewtopic.php?p=1588446&sid=e22da3a1dd88ac0104ba4ad3ad437474#p1588446